HnetInfo Benchmark v1.0
Program k měření výkonu systému a jeho komponent
Program Vám umožní měřit vlastnosti a výkon procesoru, paměti, pevného disku, grafické karty, CD-ROM/DVD mechanik a OpenGL. Můžete vytvářet textové i html reporty Vašich výsledků.
Ovládání tohoto programu je velice jednoduché a intuitivní. Čtěte si návěští a nápovědy tlačítek a tuto nápovědu.

Program je rozdělen do šesti základních kategorií podle testovaného zařízení (CPU/FPU, Paměť, Pevný disk, Grafická karta, CD-ROM, OpenGL). V každé kategorii můžete otestovat svůj vlastní systém a výsledky porovnat s jinými podobnými systémy.

Kategorie

  • CPU/FPU
  • Paměť
  • Pevný disk
  • Grafická karta
  • CD-ROM
  • OpenGL
    • Ostatní

  • Vytváření reportu a práce s menu
  • Co je nového v programu?
    • Vyberte prosím jednu kategorii pro detailní popis.


CPU/FPU
Centrální procesorová jednotka / Jednotka plovoucí čárky (koprocesor)
Pro začátek měření stiskněte tlačítko Měření CPU/FPU.

Hlavní CPU

HnetInfo Benchmark detekuje typ a různe parametry (výrobce, typ, rodina, ...) Vašeho procesoru.

L1 Cache - Velmi rychlá paměť integrovaná v procesoru, která udržuje data, ke kterým se často přistupuje. Některé procesory mají oddělenou cache pro programové instrukce (code) a pro data. Ostatní mají tuto cache sjednocenou. Velikost paměťi je asi 1kB až 64kB. L1 cache běží většinou na stejné frekvenci jako sběrnice procesoru.

L2 Cache - Některé procesory mají cache paměť druhé úrovně, která je větší než L1 cache (64kB až 2MB), ale která je však pomalejší. Tato cache může být opět vestavěná (např. v čipu, jako u procesoru Celeron) nebo může být na základni desce (např. jako u procesoru Pentium II)

Rysy procesoru

Informace o schopnostech Vašeho procesoru
FPU zabudován v CPU - určuje, zda je koprocesor (pokud je dostupný) vestavěný v procesoru nebo externí.

Rozšíření virtuálního módu - (VME) CPU podporuje rozšíření pro mód V86, který typicky zvyšuje rychlost virtuálních "strojů" pod Windows.

Ladící rozšíření - (DE) CPU podporuje nastavení ladících bodů ve V/V adresním prostoru.

Rozšíření velikosti tabulky paměti - (PSE) Standardní velikost stránky je 4KB. Některé procesory mohou podporovat různé velikosti stránky (4MB), což je výhodné, pokud je v systému instalováno větší množství paměti.

Počítadlo časových známek - Interní počítadlo zvyšující se při každém cyklu hodin, které dovoluje větší přesnost měření.

Specifické registry modelu - (MSR) CPU má speciální (specifické vzhledem k modelu) interní registry.

Rozšíření fyzické adresy - (PAE) V systému je podporovaná fyzická adresa širší než 32 bitů.

Výjimka kontroly stroje - (MCE) Výjimka 18 je podporovaná.

CMPXCHG8B instrukce (64-bitové porovnávání) - (CX8) Instrukce pro porovnání a výměnu 8 bytů.

Podpora multiprocesorových systémů (APIC aktivní) - Pokročilý ovladač přerušení, který je rychlejší a může být použit pro multiprocesorové systémy, je vestavěný.

Podpora rychlého systémového volání (SYSENTER/SYSEXIT) - (FSC) Podpora instrukcí SYSCALL & SYSRET.

Rozsahové paměťové registry - (MTRR) Podpora speciálních registrů, které zlepší propustnost vyrovnávací paměti.

Rozšíření globální tabulky - (GPE) CPU podpporuje zapnutí/vypnutí globálních stránek (tabulek).

Architektura kontroly stroje - (MCA) Interní test procesoru je dostupný.

CMOV instrukce - (CMOV) Umožňuje spouštění instrukcí na základě splnění podmínky bez skoků.

Sériové číslo - (PSN) CPU má jedinečné číslo, které je viditelné softwaru.

MMX - Multimediální rozšíření sady instrukcí přidané firmou Intel pro zrychlení multimediálních aplikací s použitím operací typu SIMD (single instruction multiple data) jako multiprocesorová pole.

AMD rozšířené 3DNow! - Rozšíření MMX přidané firmami Cyrix & AMD.

AMD 3DNow! - toto je sada instrukcí přidaných firmou AMD pro zrychlení 3D multimediálních aplikací používajících procesor. Narozdíl od MMX, pracuje s daty plovoucí čárky. Podpora je integrovaná v DirectX 6 a pozdějších.

IntelStreaming SIMD extension - Supersada MMX sad instrukcí přidaných firmou Intel pro zrychlení multimediálních aplikací s použitím operací typu SIMD (single instruction multiple data) jako multiprocesorová pole. Zatímco MMX pracuje s celočíselnými daty, SSE pracuje s daty plovoucí čárky. Podpora je obsažená v DirectX 6.1 a pozdějších.

MMX je rozšíření instrukční sady x86, které umožňuje, aby více bytů dat bylo sbaleno dohromady v jednom registru a zpracováno najednou. MMX se skládá z 57 nových instrukcí pro zrychlení multimediálních úloh. Trik těchto nových instrukcí spočívá v tom, že mohou zpracovat množství různých datových elementů najednou. To zvyšuje celkové množství práce, kterou může procesor udělat. Příklady mohou být od zpracování množiny bodů v bitmapovém obrázku až po zvukové kanály ve zvukovém toku. MMX není urychlující technologijí pro grafiku nebo multimédia, ale toto jsou právě ty typy aplikací, které z toho těží nejvíce. MMX zprostředkuje substanční zvýšení výkonu některých nových aplikací napsaných s využitím MMX (více u domácích než obchodních aplikací).

SSE(2) rozšíření instrukční sady MMX, navržené ke zvýšení softwarového výkonu v aplikacích 3D grafiku, 3D geometrii, zpracování signálů, simulaci, video a softwarovou 3D rasterizaci, komprimaci/dekomprimaci videa (např. MPEG, MPEG2).
Měření

Měří, jakým způsobem si Váš procesor stojí, ve srovnání s ostatními typickými systémy.
Celočíselné operace Měří index celočíselných operací (Integer) hlavního procesoru.

Operace v plovoucí čárce Měří index operací v plovoucí čárce (Floating Point) hlavního procesoru.

Pi index Měří výpočet konstanty Pi s přesností na 2000 desetinných míst.

Matice Měří index násobení matic řádu 250.

Prvočísla Měří výpočet prvních 10 000 prvočísel.

Dhrystony (MIPS) Počítá test Dhrystone. Výsledek je v MIPS (milionech instrukcí za sekundu).

Whetstony (MWIPS) Počítá test Whetstone. Výsledek je v MWIPS (milionech whetstone instrukcí za sekundu).
Další kapitola: Paměť
Hlavní strana


Paměť
Detekce modulů paměti a jejich testování
Testuje, jakým způsobem si Váš paměťový subsystém stojí ve srovnání s jinými systémy se stejnými nebo podobnými paměťovými moduly.

Obsazená paměť

Jaké množství Vaší paměti je obsazeno.

Fyzická paměť

Jaké množství Vaší fyzické paměti je volné.

Detekce paměťových modulů

Program detekuje, jakým způsobem jsou na Vaší základní desce osazeny paměťové moduly.

Měření

Pro měření paměti jednodušše stiskněte tlačítko Měření paměti.
Výsledek měření je v MB/s.

Další kapitola: Pevný disk
Předchozí kapitola: CPU/FPU


Pevný disk
Měření pevného disku
Testuje, jak si stojí Váš pevný disk a řadič ve srovnání s jinými podobnými systémy.

Program testuje náhodný přístup vaší jednotky v ms a přenosovou rychlost v MB/s.
Pro měření parametrů Vaší jednotky pevného disku jednodušše stiskněte tlačítko Měření vybraného disku na zvolené jednotce.

  • Test vyžaduje 10MB nebo více volného místa na testované jednotce.

    Zatížení CPU během testu je vysoké. Moderní ATA a SCSI řadiče disků používají DMA přenos, který snižuje zatížení CPU při přenosu dat z/na disk a zvyšuje tak celkový výkon systému. Takové systému používají maximálně 10% času CPU, zatímco u jiných systémů je to okolo 90-99% času CPU během přenosu dat.

    Další kapitola: Grafická karta
    Předchozí kapitola: Paměť


Grafická karta
Detekce a měření grafické karty
Zobrazí základní informace o video adaptéru instalovaném v systému.

Adaptér

Jméno adaptéru, pokud je úspěšne detekováno.

Čipová sada

Jméno čipové sady osazené na adaptéru.

DAC

Typ DAC na adaptéru.

Paměť

Množství lokální (osazené na desce) instalované paměti.

Měření

Test měří počet BitBlt, PaintRgn, Bitmap, Ikon, Znaků a Polygonů vukreslených na obrazovku během dané časové jednotky.

Výsledky jsou v jednotkách za sekundu (přičemž jednotkou je jedna z BitBlt, PaintRgn, Bitmaps, Ikon, Znaků a Polygonů).

Pro spuštění měření grafické karty jednodušše stiskněte tlačítko Měření grafické karty.

Další kapitola: CD-ROM
Předchozí kapitola: Pevný disk


CD-ROM
Měření jednotek CD a DVD
Testuje, jak si Vaše CD-ROM/DVD jednotka stojí ve srovnání s ostatními CD-ROM/DVD jednotkami.

Skládá se z testů náhodného přístupu a sekvenčního čtení.

Pro test je vyžadován 600MB+ datový disk, který obsahuje (64MB+) velký datový soubor. Ideální jsou disky obsahující MPEG, MOV, AVI nebo velké databázové soubory. Plné VideoCD nebo DVD disk je doporučován. Při použití jiných disků mohou mít naměřené výsledky vyšší hodnoty a nepřesnost.

Před měřením byste měli vybrat testovanou jednotku a disk. Program není schopen otestovat Vaši jednotku bez CD nebo DVD vloženého do Vaší jednotky.

Pro začátek měření stiskněte tlačítko Sekvenční čtení nebo Náhodný přístup. Tlačítko Prohledat jednotky použijte k výběru jednotky a souboru na vloženém CD/DVD v jednotce.

V některých verzích Microsoft® Windows můžete zvolit Synchronní/Asynchronní čtení během testu. V ostatních je tato možnost zakázána a je programem automaticky detekována správná možnost.

Během měření je zobrazen graf průběhu testu zvolené jednotky.

Další kapitola: OpenGL
Předchozí kapitola: Grafická karta


OpenGL
Detekce a test OpenGL
OpenGL je průmyslový standard pro 2D & 3D renderování, nezávislé na grafickém adaptéru, výrobci a operačním systému. Je velmi univerzální a obsahuje podporu všech vlastností (mapování textur, mlha, rozostření pohybem, atd.). Je integrováno ve Windows NT/200X, přestože OpenGL ICD/MCD je vyžadováno pro vyšší výkon.

  • Výrobce - společnost, která napsala ovladač (OEM výrobce).

  • Renderovací systém - typ renderovacího systému, většinou jménu adaptéru.

  • OpenGL verze - plná verze renderovacího systému.

  • OpenGL rozšíření
    • OpenGL rozšíření je mechanizmus, který výrobcům umožňuje přidávat různé schopnosti do implementace, kterou mohou využít programy ke zvýšení výkonu.

    Pokud vlastníte moderní grafickou kartu, pak může ovladač obsahovat ICD/MCD pro akceleraci OpenGL funkci. To Vám umožní lépe využít OpenGL software a hry na Vašem počítači. Zkontrolujte, zda je pro Vaši kartu dostupný OpenGL ovladač.

    Měření

    Pro začátek měření vyberte rozlišení a stiskněte tlačítko Spustit test.

    Pokud je vybrána možnost použít aktuální rozlišení, pak nebude program měnit aktuální systémové rozlišení během testu. Rozlišení obrazovky a barevná hloubka má vliv na naměřené hodnoty.

    Výsledky jsou zobrazeny v FPS (snímcích za sekundu).

    Další kapitola: Vytváření reportu a práce s menu
    Předchozí kapitola: OpenGL


Vytváření reportu a práce s menu
Popis tvorby reportu a práce s menu programu HnetInfo Benchmark
Struktura menu HnetInfo Benchmarku

Soubor

  • Vytvořit zprávu
    Umožňuje vytvořit textovou a html verzi reportu. Průvodce reportu je velmi jednoduchý a je snadnou cestou pro získání profesionálního a detailního reportu v několika sekundách.

    Pouze vyberete měření všeho ještě jednou nebo použít naměřené hodnoty a výstupní formát. YVýsledky také můžete zaslat elektronickou poštou, pokud stisknete tlačítko Poslat mailem. Jinak stiskněte tlačítko Uložit zaprávu...

    Pro otevření průvodce také můžete stisknout Ctrl+R.
  • Jazyk
    Umožní změnit jazyk aplikace, pokud je nějaký jiný dostupný.
  • Konec
    Ukončí aplikaci. Lze použít zkratku Alt+F4.
    Měření

  • Vše
    Spustí měření všech komponent (CPU/FPU, Paměť, Pevný disk, Grafická karta, CD-ROM a OpenGL).
  • CPU/FPU
    Spustí měření CPU/FPU.
  • Paměť
    Spustí měření paměti.
  • Pevný disk
    Spustí měření pevného disku.
  • Grafická karta
    Spustí měření grafické karty.
  • CD-ROM
    Spustí měření jednotky CD-ROM.
  • OpenGL
    Spustí měření OpenGL.
    Pomoc

  • O aplikaci
    Zobrazuje informace o oplikaci a firmě Hnet Software.
  • Obsah
    Zobrazí tuto nápovědu.

    Další kapitola: Co je nového?
    Předchozí kapitola: OpenGL


Co je nového?
Horké novinky ve vyšlích verzích
Toto je první verze HnetInfo Benchmarku.

Předchozí kapitola: Vytváření reportu a práce s menu